New CC processing problem.Did anything change with CCs with the update?

We just got to running the latest update yesterday(just noticed it, apparently a little late) and now when processing cc's instead of going to the swipe card screen, it goes to a screen that looks like the keyed entry screen, (it says swipe or key the cc into card number field and it shows entry boxes for exp date, security pin, adress etc). Initially it has a green bar over top of it saying "communicating" for a while. Sometimes it finishes and lets you swipe the card into that screen but must also enter security pin, other times is sits there for a while the says "The operation has timed out. Please try again.". If it lets you swipe the card,a while after it has been transmitting it will say approved but then has an error something like [timed out. POS must close.]or something like that and doesn't actually run the card. We only have had to attempt 3 cards but only one actually ran all the way through and thats after trying 3 times. I ran the other cards by using the x-charge virtual terminal so its not the card, our card reader or merchant services. i tried closing out RGP and even restarting the computer but the different screen always comes up now for POS cc method of payment.

Has this happened to anyone else and how can I fix it. Using the virtual teminal works for now but it'll be a pain trying to reconcile it on the POS system/in the books etc. Until cc works i'm entering it as cash trnsactions with notes that it really is credit, so we'll see how that goes.



1 comment
  • Yes, things significantly changed to accommodate the PCI mandate from the credit card agency. The new "swipe" window is actually a small website at XCharge - which allows RGP to never see the credit card.

    Yours is the first report of any trouble with that swipe window out of 80+ gyms, so something is odd with your internet explorer setup, your internet connection, or the way your account is setup at XCharge.

    I'll put you in contact with someone at XCharge that can help you troubleshoot it - to see if it is a problem on their side with your setup. On your side, do you use Internet Explorer for the web? Is it working properly?

    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post